加入收藏
 

KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图

2019-10-09 09:46:49推荐星级:下载统计()
奇爱股票网提供KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图说明

KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图

看了K线哥关于KDJ的用法,保留我的看法。其J<10的理念,只是短期超跌的概念,我认为是没有特别意义的。当J<0其实就属于超跌,是否形成底部,是很难得到认定的。要具备操作性,我认为可靠边的方法是形成底背离后才会更具操作性。

K线哥提出的J>50且站上5日线的介入法,这个我是非常认同,蝴蝶信号就是基于这种理念而写的。

指标编写具有局限性,符合条件的才能出信号,所以只当提示。


MA10:MA(C,10),COLOR00FFFF,NODRAW;
MA5:MA(C,5),COLOR0000FF,NODRAW;


HH9:=HHV(H,9);
LL9:=LLV(L,9);
RSVZ9:=(C-LL9)/(HH9-LL9);
K:=SMA(RSVZ9*100,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
KZ9:=SMA(RSVZ9,3,1);
DZ9:=SMA(KZ9,3,1);
JZ9:=3*KZ9-2*DZ9;

ZTK9:=KZ9*(HH9-LL9)+LL9;
ZTD9:=DZ9*(HH9-LL9)+LL9;
ZTJ9:JZ9*(HH9-LL9)+LL9,COLORDDDDDD,NODRAW;
ZTJE:=EMA(ZTJ9,3);
HYY50:(H/((HH9+LL9)/2)-1)*100,NODRAW;
JCJ:=(ZTJ9/((H+MAX(C,O))/2)-1)*100;


YY20:=0.20*(HH9-LL9)+LL9;
YY25:=0.25*(HH9-LL9)+LL9;
YY50:0.5*(HH9-LL9)+LL9,COLORFF0000,DOTLINE,NODRAW;
YY45:=0.45*(HH9-LL9)+LL9;
YY65:=0.65*(HH9-LL9)+LL9;
YY70:=0.70*(HH9-LL9)+LL9;
YY78:=0.78*(HH9-LL9)+LL9;
YY85:=0.85*(HH9-LL9)+LL9;
YY95:=0.95*(HH9-LL9)+LL9;


LLKB:=LLV(L,BARSLAST(CROSS(50,K))+1);
HHKB:=HHV(H,BARSLAST(CROSS(K,50))+1);
LDKL:=LLV(L,BARSLAST(CROSS(EMA(ZTJ9,3),ZTJ9))+1);
LDKJ:=LLV(ZTJ9,BARSLAST(CROSS(EMA(ZTJ9,3),ZTJ9))+1);

RSVZ34:=(C-LLV(L,34))/(HHV(H,34)-LLV(L,34));
KZ34:=SMA(RSVZ34,3,1);
DZ34:=SMA(KZ34,3,1);
JZ34:=3*KZ34-2*DZ34;
ZTK34:=KZ34*(HHV(H,34)-LLV(L,34))+LLV(L,34);
ZTD34:=DZ34*(HHV(H,34)-LLV(L,34))+LLV(L,34);
ZTJ34:=JZ34*(HHV(H,34)-LLV(L,34))+LLV(L,34);

DRAWBAND(0.5*(HH9-LL9)+LL9,RGB(60,80,84),0.25*(HH9-LL9)+LL9,DRAWNULL);
DRAWBAND(IF(ZTJ34>=(HHV(H,34)+LLV(L,34))/2,(HH9+LL9)/2,DRAWNULL),RGB(80,55,84),IF(ZTJ34>=(HHV(H,34)+LLV(L,34))/2,0.25*(HH9-LL9)+LL9,DRAWNULL),DRAWNULL);

XXX_101:=ZTJ9;
XXX_102:=ZTD9;

STICKLINE(C<O,H,L,0,0),COLORFFF000;
STICKLINE(C<O,C,O,3.2,1),COLORFFF000;
STICKLINE(C>=O,H,L,0,0),COLOR0000FF;
STICKLINE(C>=O,C,O,3.2,1),COLOR0000FF;

STICKLINE(ZTK9<YY25 AND C<O,H,L,0,0),COLORFF0000;
STICKLINE(ZTK9<YY25 AND C<O,C,O,3.2,1),COLORFF0000;
STICKLINE(ZTK9<YY25 AND C>=O,H,L,0,0),COLORC050AA;
STICKLINE(ZTK9<YY25 AND C>=O,C,O,3.2,1),COLORC050AA;


STICKLINE(ZTJ9>=ZTJE,C,O,3.2,0),COLOR225599;
STICKLINE(ZTJ9>=ZTJE,C,O,1.5,0),COLOR2255AA;
STICKLINE(ZTJ9>=ZTJE,C,O,0.4,0),COLOR2255BB;

STICKLINE(ZTJ9>=ZTJE AND XXX_101>=XXX_102,C,O,3.2,0),COLOR000077;
STICKLINE(ZTJ9>=ZTJE AND XXX_101>=XXX_102,C,O,1.5,0),COLOR000088;
STICKLINE(ZTJ9>=ZTJE AND XXX_101>=XXX_102,C,O,0.4,0),COLOR000099;

STICKLINE(ZTJ9<ZTJE AND XXX_101>=XXX_102,C,O,3.2,0),COLORC0C0C0;
STICKLINE(ZTJ9<ZTJE AND XXX_101>=XXX_102,C,O,1.5,0),COLORD0D0D0;
STICKLINE(ZTJ9<ZTJE AND XXX_101>=XXX_102,C,O,0.4,0),COLORE0E0E0;

STICKLINE(ZTK9>=YY45,MAX(C,O),(C+O)/2,3.2,0),COLOR770088;
STICKLINE(ZTK9>=YY45,MAX(C,O),(C+O)/2,1.5,0),COLOR880099;
STICKLINE(ZTK9>=YY45,MAX(C,O),(C+O)/2,0.4,0),COLOR9900AA;

STICKLINE(ZTK9>=YY65,MAX(C,O),(C+O)/2,3.2,0),COLOR0000DD;
STICKLINE(ZTK9>=YY65,MAX(C,O),(C+O)/2,1.5,0),COLOR0000EE;
STICKLINE(ZTK9>=YY65,MAX(C,O),(C+O)/2,0.4,0),COLOR0000FF;

STICKLINE(ZTK9>=YY78,MAX(C,O),(C+O)/2,3.2,0),COLORFF0060;
STICKLINE(ZTK9>=YY78,MAX(C,O),(C+O)/2,1.5,0),COLORFF0070;
STICKLINE(ZTK9>=YY78,MAX(C,O),(C+O)/2,0.4,0),COLORFF0080;

STICKLINE(ZTK9>=YY85,MAX(C,O),(C+O)/2,3.2,0),COLOR00BBCC;
STICKLINE(ZTK9>=YY85,MAX(C,O),(C+O)/2,1.5,0),COLOR00CCDD;
STICKLINE(ZTK9>=YY85,MAX(C,O),(C+O)/2,0.4,0),COLOR00DDEE;

STICKLINE(ZTK9>=YY45 AND C<O,(C+O)/2,C,3.2,0),COLORDDDD00;
STICKLINE(ZTK9>=YY45 AND C<O,(C+O)/2,C,1.5,0),COLOREEEE00;
STICKLINE(ZTK9>=YY45 AND C<O,(C+O)/2,C,0.4,0),COLORFFFF00;

STICKLINE(ZTK9>=YY85 AND C<O,(C+O)/2,C,3.2,0),COLOR00DD00;
STICKLINE(ZTK9>=YY85 AND C<O,(C+O)/2,C,1.5,0),COLOR00EE00;
STICKLINE(ZTK9>=YY85 AND C<O,(C+O)/2,C,0.4,0),COLOR00FF00;

STICKLINE(REF(COUNT(K>D AND ZTJ9>REF(ZTJ9,1),2)=2,1) AND K<REF(K,1) AND C<O AND C<REF((C+O)/2,2),REF((C+O)/2,2),REF((C+O)/2,2),6,-1),COLOR00FF00;

YY50,COLORFF0000,DOTLINE;
ZTJ9,COLOR888888;
MA10,COLOR00FFFF;
MA5,COLOR0000FF;


KD9死叉T:=BARSLAST(CROSS(ZTD9,ZTK9));
KD9死叉T0:=KD9死叉T+1;
KD9死叉1:=REF(KD9死叉T,KD9死叉T+1)+KD9死叉T;
KD9死叉T1:=KD9死叉1+1;
KD9死叉2:=REF(KD9死叉T1,KD9死叉T+1)+KD9死叉T;
KD9死叉T2:=KD9死叉2+1;
KD9死叉3:=REF(KD9死叉T2,KD9死叉T+1)+KD9死叉T;
KD9死叉T3:=KD9死叉3+1;
KD9金叉T:=BARSLAST(CROSS(ZTK9,ZTD9));
KD9金叉T0:=KD9金叉T+1;
KD9金叉1:=REF(KD9金叉T,KD9金叉T+1)+KD9金叉T;
KD9金叉T1:=KD9金叉1+1;
KD9金叉2:=REF(KD9金叉T1,KD9金叉T+1)+KD9金叉T;
KD9金叉T2:=KD9金叉2+1;
KD9金叉3:=REF(KD9金叉T2,KD9金叉T+1)+KD9金叉T;
KD9金叉T3:=KD9金叉3+1;

DBX:=IF(ZTK9>=ZTD9,LLV(L,KD9死叉T0),DRAWNULL),COLORFF0000;
DBX2:=IF(ZTK9>=ZTD9,LLV(L,KD9死叉T1),DRAWNULL),COLOR00FFFF;
KD9底背离:=CROSS(K,D) AND DBX>DBX2;


J高风险:=(HHV(J,7)>=109.5 AND J>100 AND ((K>78 AND KZ34<0.6) OR (K>84 AND KZ34>0.8))) OR (JCJ>4 AND K>78);{www.goodgupiao.com}
DRAWICON(J高风险,ZTJ9,2);
明天新低:=CROSS(ZTD9,ZTK9) AND C<O AND C<REF((C+O)/2,2);
DRAWICON(明天新低,H*1.015,12);
跟庄介入:=CROSS(ZTJ9,YY50) AND ZTJ9>MA(C,5) AND (MA(C,5)/REF(MA(C,5),1)-1)*100>0.1 AND ZTJ9>REF(ZTJ9,1) AND (MAX(C,O)+H)/2>YY50 AND O/LLV(L,5)<1.2 AND COUNT(MIN(C,O)<YY25,7)>0;
DRAWICON(跟庄介入,YY20,29);
DRAWICON(跟庄介入 AND ZTJ34>=(HHV(H,34)+LLV(L,34))/2,YY20,30);
K线哥:=跟庄介入 AND COUNT(J<-10,7)>0;
DRAWTEXT(K线哥,H*1.015,'↙K线哥'),COLORFFFFFF;


K线哥TJ2:=CROSS(C,(HHV(H,9)+LLV(L,9))/2) AND C>MA(C,5) AND ZTJ9>MA(C,5);
K线哥TJ1:=CROSS(ZTJ9,ZTJE);
K线哥TJ:=K线哥TJ1 AND LLV(ZTJ9,5)>REF(LLV(ZTJ9,5),BARSLAST(REF(K线哥TJ1,1))) AND LLV(MIN(C,O),5)*1.002>REF(LLV(L,5),BARSLAST(REF(K线哥TJ1,1))) AND
REF(LLV(KDJ.J,6),BARSLAST(REF(K线哥TJ1,1)))<-9.9;
DRAWTEXT(COUNT(K线哥TJ,6)>0 AND K线哥TJ2,0.2*(HH9-LL9)+LL9,'↖K线哥'),COLOR00FFFF;


乌云ZT:=(O-REF(H,1))/REF(H,1)*100>0;
乌云实体:=(MAX(C,O)-MIN(C,O))/MIN(C,O)*100>2 AND C<O;
乌云盖顶:=乌云ZT AND 乌云实体;
上十字星:=(H-L)/ABS(C-O)>3 AND H>MAX(C,O) AND H>REF(H,1);
见顶K线:=(上十字星 OR 乌云盖顶) AND HHKB/LLKB>1.49 AND (H=HHV(H,3) OR HHV(MAX(C,O),3)=MAX(C,O));
顶背迹象:=HHV(H,BARSLAST(CROSS(K,50))+1)>K AND HHV(H,BARSLAST(CROSS(K,50))+1)=H AND COUNT(K>78,7)>0;
随时逃:=见顶K线 AND ((COUNT(J>100,5)>0 OR COUNT(K>84,5)>0) OR 顶背迹象);
DRAWTEXT(随时逃,H*1.015,'↙随时逃'),COLOR00FF00;

KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图

KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图

KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图

KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图

KDJ主图之k线哥理念综合 通达信主图指标 源码 贴图

推荐下载

赞助商广告