加入收藏
 

连续买卖信号过滤的方法

2014-04-04 14:26:59推荐星级:下载统计()
奇爱股票网提供连续买卖信号过滤的方法下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

连续买卖信号过滤的方法说明

代码片段(通达信):

{过滤前的买卖信号}
BUY:= 你的买进信号;
SELL:= 你的卖出信号;

B2:=BARSLAST(BUY);
S2:=BARSLAST(SELL);

{过滤多余买卖信号的条件}
FBUY:=CROSS(S2,B2);
FSELL:=CROSS(B2,S2);

过滤后的买进信号:= BUY AND FBUY;
过滤后的卖出信号:= SELL AND FSELL;


示例代码:

过滤前:C;
{过滤前的买卖信号}
BUY:= C>REF(C,1)*1.05;
SELL:= C<REF(C,1)*0.97;

B2:=BARSLAST(BUY);
S2:=BARSLAST(SELL);

{过滤多余买卖信号的条件}
FBUY:=CROSS(S2,B2);
FSELL:=CROSS(B2,S2);

BUYNEW:= BUY AND FBUY;
SELLNEW:= SELL AND FSELL;

过滤后: 过滤前+5;
DRAWICON(BUYNEW,过滤后,1);
DRAWICON(SELLNEW,过滤后,2);

DRAWICON(BUY, 过滤前,1);
DRAWICON(SELL, 过滤前,2);

推荐下载

Tag标签

赞助商广告