加入收藏
 

分时二次突破 大智慧/飞狐指标 源码 贴图

2021-02-15 08:51:59推荐星级:下载统计()
奇爱股票网提供分时二次突破 大智慧/飞狐指标 源码 贴图下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

分时二次突破 大智慧/飞狐指标 源码 贴图说明

分时二次突破 大智慧/飞狐指标 源码 贴图


有人问到分时量比的问题,解释比较麻烦,发个指标供参考

仅供参考,其中一些条件能改成你自己的思路最好!

大智慧飞狐都一样,先建名为Z01的指标,以前已有Z01指标看情况把源码加到后面

{Z01}
昨量:REF(V,1);
VM5:REF(MA(V,5),1);

再建选股指标,预警是周期选择1分钟
{大智慧版,有kingwa这个DLL文件就用这个,默认自动到自选股3板块,要建个自选股3}
{分时二突}
SJ:=BARSLAST(DAY<>REF(DAY,1) OR BARPOS=1)+1;
LB:=SUM(V,SJ)*240/DYNAINFO(38)/SJ;
LBA:=V/("Z01.昨量#DAY"/240);
LBB:=V/(DYNAINFO(38)/1200);
ZDH:=H/DYNAINFO(3); ZDC:=C/DYNAINFO(3);
A1:=BARSLAST(MA(C,2)<REF(MA(C,2),1));
A2:=C/REF(C,A1)>=1.024 AND HHV(ZDC,A1+1)>=1.024;{一波涨幅}
A3:=HHV(LBA,A1+1)>=4 AND HHV(LBB,A1+1)>=10 AND TIME<=102100;{量}
A4:=BARSLAST(CROSS(0.5,A2 AND A3));{起点}
A5:=REF(HHV(ZDH,SJ),A4+1)<=1.07;{最大涨幅限制};
A6:=COUNT(C>=DYNAINFO(3),SJ)=SJ;{没跌破昨收};
A7:=HHV(H,SJ)/LLV(L,SJ)<=1.045;{振幅限制};
B1:=(C-REF(LLV(L,SJ),A4))/(REF(HHV(H,SJ),A4)-REF(LLV(L,SJ),A4));{KD}
B2:=MAX(MA(C,5),MA(C,10),MA(C,20))/MIN(MA(C,5),MA(C,10),MA(C,20))<=1.003;
B3:=ALL(MA(C,20)>REF(MA(C,20),1),15) AND MA(C,5)>MA(C,20) AND MA(C,10)>MA(C,20);
B4:=ALL(C>O AND C>REF(C,1),3) AND B1>0.6 AND B1<1 AND B2 AND B3;
B5:=CROSS(B1,0.9) OR CROSS(B1,0.95) OR REF(B4,1);
C1:=B5 AND A5 AND A6 AND A7 AND LB>=3 AND TIME>=93700 AND TIME<=102100;{信号}
TC:=STRFIND(STKNAME,'S',1)=0 AND CAPITAL/100/10000<=20 AND DYNAINFO(8)>=100;{剔除ST};
预警:C1 AND TC;
if 预警 then
begin
aa1:="kingwa@save2blk"(预警,3);
end;

{大智慧版,没有kingwa这个DLL文件就用这个}
{分时二突}
SJ:=BARSLAST(DAY<>REF(DAY,1) OR BARPOS=1)+1;
LB:=SUM(V,SJ)*240/DYNAINFO(38)/SJ;
LBA:=V/("Z01.昨量#DAY"/240);
LBB:=V/(DYNAINFO(38)/1200);
ZDH:=H/DYNAINFO(3); ZDC:=C/DYNAINFO(3);
A1:=BARSLAST(MA(C,2)<REF(MA(C,2),1));
A2:=C/REF(C,A1)>=1.024 AND HHV(ZDC,A1+1)>=1.024;{一波涨幅}
A3:=HHV(LBA,A1+1)>=4 AND HHV(LBB,A1+1)>=10 AND TIME<=102100;{量}
A4:=BARSLAST(CROSS(0.5,A2 AND A3));{起点}
A5:=REF(HHV(ZDH,SJ),A4+1)<=1.07;{最大涨幅限制};
A6:=COUNT(C>=DYNAINFO(3),SJ)=SJ;{没跌破昨收};
A7:=HHV(H,SJ)/LLV(L,SJ)<=1.045;{振幅限制};
B1:=(C-REF(LLV(L,SJ),A4))/(REF(HHV(H,SJ),A4)-REF(LLV(L,SJ),A4));{KD}
B2:=MAX(MA(C,5),MA(C,10),MA(C,20))/MIN(MA(C,5),MA(C,10),MA(C,20))<=1.003;
B3:=ALL(MA(C,20)>REF(MA(C,20),1),15) AND MA(C,5)>MA(C,20) AND MA(C,10)>MA(C,20);
B4:=ALL(C>O AND C>REF(C,1),3) AND B1>0.6 AND B1<1 AND B2 AND B3;
B5:=CROSS(B1,0.9) OR CROSS(B1,0.95) OR REF(B4,1);
C1:=B5 AND A5 AND A6 AND A7 AND LB>=3 AND TIME>=93700 AND TIME<=102100;{信号}
TC:=STRFIND(STKNAME,'S',1)=0 AND CAPITAL/100/10000<=20 AND DYNAINFO(8)>=100;{剔除ST};
预警:C1 AND TC;

{飞狐版,有自动预警到板块功能}
{分时二突}
SJ:=BARSLAST(DAY<>REF(DAY,1) OR BARPOS=1)+1;
LB:=SUM(V,SJ)*240/"Z01.VM5#DAY"/SJ;
LBA:=V/("Z01.昨量#DAY"/240);
LBB:=V/("Z01.VM5#DAY"/1200);
ZDH:=H/DYNAINFO(3); ZDC:=C/DYNAINFO(3);
A1:=BARSLAST(MA(C,2)<REF(MA(C,2),1));
A2:=C/REF(C,A1)>=1.024 AND HHV(ZDC,A1+1)>=1.024;{一波涨幅}
A3:=HHV(LBA,A1+1)>=4 AND HHV(LBB,A1+1)>=10 AND TIME<=102100;{量}
A4:=BARSLAST(CROSS(0.5,A2 AND A3));{起点}
A5:=REF(HHV(ZDH,SJ),A4+1)<=1.07;{最大涨幅限制};
A6:=COUNT(C>=DYNAINFO(3),SJ)=SJ;{没跌破昨收};
A7:=HHV(H,SJ)/LLV(L,SJ)<=1.045;{振幅限制};
B1:=(C-REF(LLV(L,SJ),A4))/(REF(HHV(H,SJ),A4)-REF(LLV(L,SJ),A4));{KD}
B2:=MAX(MA(C,5),MA(C,10),MA(C,20))/MIN(MA(C,5),MA(C,10),MA(C,20))<=1.003;
B3:=ALL(MA(C,20)>REF(MA(C,20),1),15) AND MA(C,5)>MA(C,20) AND MA(C,10)>MA(C,20);
B4:=ALL(C>O AND C>REF(C,1),3) AND B1>0.6 AND B1<1 AND B2 AND B3;
B5:=CROSS(B1,0.9) OR CROSS(B1,0.95) OR REF(B4,1);
C1:=B5 AND A5 AND A6 AND A7 AND LB>=3 AND TIME>=93700 AND TIME<=102100;{信号}
TC:=STRFIND(STKNAME,'S',1)=0 AND CAPITAL/100/10000<=20 AND DYNAINFO(8)>=100;{剔除ST};
预警:C1 AND TC;

分时二次突破 大智慧/飞狐指标 源码 贴图


 

推荐下载

赞助商广告