加入收藏
 

同花顺指标 源码 TRIX0 贴图

2018-01-12 11:20:07推荐星级:下载统计()
奇爱股票网提供同花顺指标 源码 TRIX0 贴图下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

同花顺指标 源码 TRIX0 贴图说明

1.TRIX由下往上交叉其平均线时,为长期买进信号;

2.TRIX由上往下交叉其平均线时,为长期卖出信号;
3.DMA、MACD、TRIX 三者构成一组指标群,互相验证。


TR=EMA(EMA(EMA(CLOSE,M1),M1),M1);
DIFF:(TR-REF(TR,1))/REF(TR,1)*100,colorred;
DEA:MA(DIFF,M2),colorblue;
MACD:2*(DIFF-DEA);
Zero:0,colorgray;
熊:-0.2,colorgreen;
牛:0.2,colorred;
AA:=CROSS(DIFF,熊);
BB:=CROSS(DIFF,牛);
DRAWTEXT(AA,-0.2,'建'),colorred;
DRAWTEXT(BB,0,'击'),colorred;
{PARTLINE(DIFF,DIFF>=REF(DIFF,1),RGB(255,0,0),
DIFF<REF(DIFF,1),RGB(0,255,0)),LINETHICK2;}
{PARTLINE(DEA,DEA>=REF(DEA,1),RGB(255,0,0),
DEA<REF(DEA,1),RGB(0,255,0)),LINETHICK1;}
STICKLINE(MACD>0AND MACD>=REF(MACD,1),0,MACD,6,0),colorred;
STICKLINE(MACD>0AND MACD<REF(MACD,1),0,MACD,3,0),colorgray;
STICKLINE(MACD<0AND MACD>=REF(MACD,1),0,MACD,3,0),colormagenta;
STICKLINE(MACD<0AND MACD<REF(MACD,1),0,MACD,3,0),colorgreen;
DRAWICON(CROSS(DIFF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIFF),DEA,2);
DRAWTEXT(DIFF>REF(DIFF,1)AND REF(DIFF,1)<REF(DIFF,2)AND DIFF<DEA,DEA,0),colorred;
低位金叉:=CROSS(DIFF,DEA)AND DIFF<-0.1;
STICKLINE(低位金叉,DEA*0.86,DEA*0.66,6,0),coloryellow;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA)AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,DEA*0.96,DEA*0.76,6,0),ColorFF00FF;
DRAWTEXT(二次金叉,0,'BUY');//www.88gs.com
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=CLOSE<REF(CLOSE,A1+1)AND DIFF>REF(DIFF,A1+1)AND CROSS(DIFF,DEA)AND DEA<0;
STICKLINE(底背离,DEA*1.09,DEA*0.86,6,0),Color00FF00;
DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,linethick1;
DRAWTEXT(底背离,DEA*1.09,'底背'),Color6600FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=CLOSE>REF(CLOSE,A2+1)AND DIFF<REF(DIFF,A2+1)AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,linethick1;
DRAWTEXT(顶背离,DEA*0.8,'顶背'),Color00FF00;

推荐下载

赞助商广告